Обновление Jooma-сайтов

обновление JoomlaОбратие внимание, что официальная поддержка Joomla 1.5 закончилась в апреле 2012 года. Официальная поддержка Joomla 2.5.x закончилась в феврале 2014 года. Все вопросы безопасности этих устаревших версий рассматривались и исправлялись до февраля 2013 и мая 2014 года соответственно.

Пока ваш сайт Joomla 1.5 или 2.5 продолжает функционировать, как и раньше. Возможно, он не перестанет работать и в самом ближайшем будущем.

Тем не менее, мы настоятельно рекомендуем вам обновить сайт до новой версии! Миграция на Joomla 3.x сэкономит вам деньги и силы, так как если ваш сайт взломают, вам придется нанимать разработчиков, чтобы устранить уязвимость и последствия взлома.

Поэтому, чтобы сохранить ваш сайт в будущем, настоятельно рекомендуем обновить его сейчас.

Подумайте об обновлении с Joomla 1.5 и 2.5 до 3.x, как об удобной возможности улучшить работу вашего сайта:

  1. Безопасность и отказоустойчивость сайта – в новой версии существует встроенный компонент блокировки атак из сети. Вы можете гибко управлять правами доступа к различным разделам или функциям сайта.
  2. Возможно, на сайте накопился устаревший или избыточный контент, или сама структура устарела, или что-то не вписывается в текущую организацию сайта и многое другое.
  3. Если вам нужны новые, дополнительные возможности? В новой версии Joomla была добавлена функциональность, которая значительно увеличивает возможности некоторые популярные расширения – интеграция с социальными сетями, защита от спама в формах обратной связи, точная и полная настройка для поискового продвижения (SEO).
  4. Есть ли у вашего сайта мобильная версия? Если вы построили ваш сайт более года назад, то вполне вероятно, что ваш сайт не имеет мобильной версии для пользователей с ipad или сматрфонами. Обновление - отличный повод добавить соответствующие функции к вашему сайту
  5. Имеет ли ваш сайт поддержку новейших браузеров для корректной работы с планшетов и смартфонов? Вполне возможно, ваш сайт был построен перед тем как Chrome набрал большую популярность у интернет аудитории.

обновить сайт на Joomla 1.5 до Joomla 2.5Вы регулярно обновляете антивирусную программу и устанавливаете обновления для операционную системы. Мы считаем крайне важным уделить внимание и обновлению вашего сайта, бесперебойная работа которого служит вашему бизнесу и помогает вам в работе.

 

Также помните, что ваш сайт содержит дополнительные расширения, которые созданы сторонними разработчиками. В какой-то момент времени, разработчики прекратят поддержку безопасности, и ваши расширения будут подвержены риску. Разработчики также, скорее всего, прекратят добавление новых функций для Joomla 1.5/2.5, и с течением времени вы будете иметь все меньше возможных компонентов, модулей и плагинов для расширения функциональности сайта.

Обратите внимание: В настоящее время в интернете замечено массовое распространение вирусного кода через сайты, созданные при помощи самых различных CMS. Вредному воздействию подвергаются сайты, созданные на старых версиях данных движков и дополнений к ним. Количество поврежденных сайтов в сети неуклонно растет из-за бездействия администраторов ресурсов и автоматизации злоумышленниками поиска уязвимых сайтов. В результате вред наносится как взломанным сайтам, так и сайтам других пользователей.

Наконец, продолжая держать сайты на старых версиях Joomla, не нужно забывать о постоянном обновлении серверного программного обеспечения на хостинге. В первую очередь это - PHP и MySQL. Как следствие - отсутствие гарантий совместимости в данном случае. Не исключено, что очередное обновление PHP может нарушить работу вашего сайта. Это означает, что вам, возможно, придется искать другой хостинг, на котором будет поддерживаться возможность запускать сайты на старых незащищенных версиях программного обеспечения.